Fixed building issues after merge
[cascardo/gnio.git] / gnio / Makefile.am
index 17f5a64..91a72b7 100644 (file)
@@ -1,14 +1,39 @@
 NULL =
 
-INCLUDES =                                     \
-       $(SAMBA_CFLAGS)                         \
-       -I$(top_srcdir)                         \
-       -I$(top_builddir)                       \
-       $(GLIB_CFLAGS)                          \
-       -DG_DISABLE_DEPRECATED
+#INCLUDES =                                    \
+#      $(SAMBA_CFLAGS)                         \
+#      -I$(top_srcdir)                         \
+#      -I$(top_builddir)                       \
+#      $(GLIB_CFLAGS)                          \
+#      -DG_DISABLE_DEPRECATED
+
+AM_CPPFLAGS = \
+        -DG_LOG_DOMAIN=\"GLib-GIO\"                     \
+        -I$(top_builddir)                               \
+        -I$(top_srcdir)                                 \
+       $(GLIB_CFLAGS)                                  \
+        $(GLIB_DEBUG_FLAGS)                             \
+        -DG_DISABLE_DEPRECATED                          \
+        -DGIO_COMPILATION
 
 lib_LTLIBRARIES=libgnio.la
 
+libgnio_la_SOURCES =        \
+       ginetaddress.c      \
+       ginet4address.c     \
+       ginet6address.c     \
+       gresolver.c         \
+       gsocketaddress.c    \
+       ginetsocketaddress.c \
+       gsocket.c \
+       gtcpserver.c \
+       gtcpclient.c \
+       gnetworkinputstream.c \
+       gnetworkoutputstream.c \
+       gasynchelper.c \
+       gnioenumtypes.c \
+        $(NULL)
+
 
 gnio_headers = \
        ginetaddress.h      \
@@ -18,25 +43,32 @@ gnio_headers =      \
        gsocketaddress.h    \
        ginetsocketaddress.h \
        gsocket.h \
+       gtcpserver.h \
+       gtcpclient.h \
+       gnio.h \
+       gnioenumtypes.h \
        gnetworkinputstream.h \
        gnetworkoutputstream.h \
        $(NULL)
 
-gioincludedir=$(includedir)/glib-2.0/gnio/
-gioinclude_HEADERS =           \
-       $(gnio_headers)
+gnioincludedir=$(includedir)/gnio/
+gnioinclude_HEADERS =          \
+       $(gnio_headers) \
+       gnioenumtypes.h
 
+BUILT_SOURCES = \
+       gnioenumtypes.h \
+       gnioenumtypes.c \
+       $(NULL)
 
-libgnio_la_SOURCES =        \
-       ginetaddress.c      \
-       ginet4address.c     \
-       ginet6address.c     \
-       gresolver.c         \
-       gsocketaddress.c    \
-       ginetsocketaddress.c \
-       gsocket.c \
-       gnetworkinputstream.c \
-       gnetworkoutputstream.c \
-        $(NULL)
+gnioenumtypes.h: $(gnio_headers) gnioenumtypes.h.template
+        ( top_builddir=`cd $(top_builddir) && pwd`; \
+          cd $(srcdir) && glib-mkenums --template gnioenumtypes.h.template $(gnio_headers) ) > \
+            gnioenumtypes.h.tmp && mv gnioenumtypes.h.tmp gnioenumtypes.h
+
+gnioenumtypes.c: $(gnio_headers) gnioenumtypes.c.template
+        ( top_builddir=`cd $(top_builddir) && pwd`; \
+          cd $(srcdir) && glib-mkenums --template gnioenumtypes.c.template $(gnio_headers) ) > \
+            gnioenumtypes.c.tmp && mv gnioenumtypes.c.tmp gnioenumtypes.c