ofpbuf: Fix trivial spelling typo.
[cascardo/ovs.git] / debian / control
index 2970915..2918d06 100644 (file)
@@ -3,93 +3,235 @@ Section: net
 Priority: extra
 Maintainer: Open vSwitch developers <dev@openvswitch.org>
 Uploaders: Ben Pfaff <pfaffben@debian.org>, Simon Horman <horms@debian.org>
-Build-Depends:
- debhelper (>= 5), autoconf (>= 2.64), automake (>= 1.10) | automake1.10, 
- libssl-dev, pkg-config (>= 0.21), po-debconf, bzip2, openssl, python,
- python-support (>= 0.8.4), procps
-Standards-Version: 3.9.1
+Build-Depends: graphviz,
+               autoconf (>= 2.64),
+               automake (>= 1.10) | automake1.10,
+               bzip2,
+               debhelper (>= 8),
+               dh-autoreconf,
+               libssl-dev,
+               libtool,
+               openssl,
+               procps,
+               python-all (>= 2.7),
+               python-qt4,
+               python-twisted-conch,
+               python-zopeinterface,
+               python-six
+Standards-Version: 3.9.3
 Homepage: http://openvswitch.org/
 
 Package: openvswitch-datapath-source
 Architecture: all
-Depends: module-assistant, bzip2, debhelper (>= 5.0.37), ${misc:Depends}
+Depends: bzip2, debhelper (>= 5.0.37), module-assistant, ${misc:Depends}
 Suggests: openvswitch-switch
-Description: Source code for Open vSwitch datapath Linux module
+Description: Open vSwitch datapath module source - module-assistant version
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  This package provides the Open vSwitch datapath module source code
  that is needed by openvswitch-switch.  The kernel module can be built
  from it using module-assistant or make-kpkg.  README.Debian in this
  package provides further instructions.
+
+Package: openvswitch-datapath-dkms
+Architecture: all
+Depends: dkms (>= 1.95), libc6-dev, make, ${misc:Depends}, ${python:Depends}
+Description: Open vSwitch datapath module source - DKMS version
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ This package provides the Open vSwitch datapath module source code
+ that is needed by openvswitch-switch.  DKMS can built the kernel
+ module from it.
 
 Package: openvswitch-common
 Architecture: linux-any
-Depends: ${shlibs:Depends}, openssl, ${misc:Depends}, python
+Depends: openssl,
+         python (>= 2.7),
+         python-six,
+         ${misc:Depends},
+         ${shlibs:Depends}
 Suggests: ethtool
 Description: Open vSwitch common components
- openvswitch-common provides components required by both openvswitch-switch
- and openvswitch-controller.
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ openvswitch-common provides components required by both openvswitch-switch
+ and openvswitch-testcontroller.
 
 Package: openvswitch-switch
 Architecture: linux-any
 Suggests: openvswitch-datapath-module
-Depends: ${shlibs:Depends}, ${misc:Depends}, openvswitch-common (= ${binary:Version}), module-init-tools, procps
+Depends: kmod | module-init-tools,
+         netbase,
+         openvswitch-common (= ${binary:Version}),
+         procps,
+         python-argparse,
+         uuid-runtime,
+         ${misc:Depends},
+         ${python:Depends},
+         ${shlibs:Depends}
 Description: Open vSwitch switch implementations
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  openvswitch-switch provides the userspace components and utilities for
- the Open vSwitch kernel-based switch.  
+ the Open vSwitch kernel-based switch.
+
+Package: ovn-common
+Architecture: linux-any
+Depends: openvswitch-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN common components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
+ .
+ ovn-common provides components required by other OVN packages.
+
+Package: ovn-host
+Architecture: linux-any
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN host components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
+ .
+ ovn-host provides the userspace components and utilities for
+ OVN that can be run on every host/hypervisor.
+
+Package: ovn-central
+Architecture: linux-any
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN central components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ ovn-central provides the userspace daemons, utilities and
+ databases for OVN that is run at a central location.
+
+Package: ovn-docker
+Architecture: any
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         python (>= 2.7),
+         python-openvswitch (= ${source:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${python:Depends},
+         ${shlibs:Depends}
+Description: OVN Docker drivers
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
+ .
+ ovn-docker provides the docker drivers for OVN.
 
 Package: openvswitch-ipsec
 Architecture: linux-any
-Depends:
- ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}, 
- ipsec-tools (>=0.8~alpha20101208), 
- racoon (>=0.8~alpha20101208),
- openvswitch-common (= ${binary:Version}),
- openvswitch-switch (= ${binary:Version}),
- python-openvswitch (= ${binary:Version})
+Depends: ipsec-tools (>=0.8~alpha20101208),
+         openvswitch-common (= ${binary:Version}),
+         openvswitch-switch (= ${binary:Version}),
+         python,
+         python-openvswitch (= ${source:Version}),
+         racoon (>=0.8~alpha20101208),
+         ${misc:Depends},
+         ${shlibs:Depends}
 Description: Open vSwitch GRE-over-IPsec support
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  The ovs-monitor-ipsec script provides support for encrypting GRE
  tunnels with IPsec.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
 
 Package: openvswitch-pki
 Architecture: all
-Depends:
- ${misc:Depends}, openvswitch-common (>= ${source:Version}),
- openvswitch-common (<< ${source:Version}.1~)
-Description: A dependency package for the Open vSwitch public key infrastructure
+Depends: openvswitch-common (<< ${source:Version}.1~),
+         openvswitch-common (>= ${source:Version}),
+         ${misc:Depends}
+Description: Open vSwitch public key infrastructure dependency package
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  openvswitch-pki provides PKI (public key infrastructure) support for
  Open vSwitch switches and controllers, reducing the risk of
  man-in-the-middle attacks on the Open vSwitch network infrastructure.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
 
-Package: openvswitch-controller
+Package: openvswitch-testcontroller
 Architecture: linux-any
-Depends:
- ${shlibs:Depends}, openvswitch-common (= ${binary:Version}),
- openvswitch-pki (= ${source:Version}), ${misc:Depends}
-Description: Open vSwitch controller implementation
- The Open vSwitch controller enables OpenFlow switches that connect to it
- to act as MAC-learning Ethernet switches.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
+Depends: openvswitch-common (= ${binary:Version}),
+         openvswitch-pki (= ${source:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: Simple controller for testing OpenFlow setups
+ This controller enables OpenFlow switches that connect to it to act
+ as MAC-learning Ethernet switches.  It can be used for initial
+ testing of OpenFlow networks.  It is not a necessary or desirable
+ part of a production OpenFlow deployment.
 
 Package: openvswitch-dbg
 Section: debug
 Architecture: linux-any
-Depends:
${shlibs:Depends}, ${misc:Depends},
openvswitch-common (= ${binary:Version}),
- openvswitch-controller (= ${binary:Version}),
- openvswitch-ipsec (= ${binary:Version}),
openvswitch-switch (= ${binary:Version})
+Depends: openvswitch-common (= ${binary:Version}),
        openvswitch-switch (= ${binary:Version}),
        ${misc:Depends},
+         ${shlibs:Depends}
+Conflicts: openvswitch-testcontroller (<< ${binary:Version}),
          openvswitch-testcontroller (>> ${binary:Version})
 Description: Debug symbols for Open vSwitch packages
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  This package contains the debug symbols for all the other openvswitch-*
  packages.  Install it to debug one of them or to examine a core dump
  produced by one of them.
@@ -97,7 +239,52 @@ Description: Debug symbols for Open vSwitch packages
 Package: python-openvswitch
 Architecture: all
 Section: python
-Depends: ${python:Depends}, openvswitch-switch (= ${binary:Version})
-Provides: ${python:Provides}
+Depends: ${misc:Depends}, ${python:Depends}
 Description: Python bindings for Open vSwitch
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  This package contains the full Python bindings for Open vSwitch database.
+
+Package: openvswitch-test
+Architecture: all
+Depends: python (>= 2.7) | python-argparse,
+         python-twisted-web,
+         ${misc:Depends},
+         ${python:Depends}
+Description: Open vSwitch test package
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
+ This package contains utilities that are useful to diagnose
+ performance and connectivity issues in Open vSwitch setup.
+
+Package: openvswitch-vtep
+Architecture: linux-any
+Depends: openvswitch-common (>= ${binary:Version}),
+         openvswitch-switch (>= ${binary:Version}),
+         python,
+         python-openvswitch (>= ${source:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: Open vSwitch VTEP utilities
+ Open vSwitch is a production quality, multilayer, software-based, Ethernet
+ virtual switch. It is designed to enable massive network automation through
+ programmatic extension, while still supporting standard management interfaces
+ and protocols (e.g. NetFlow, sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In
+ addition, it is designed to support distribution across multiple physical
+ servers similar to VMware's vNetwork distributed vswitch or Cisco's Nexus
+ 1000V.
+ .
+ This package provides utilities that are useful to interact with a
+ VTEP-configured database and a VTEP emulator.