Import Debian changes 1.18-1
[cascardo/sendxmpp.git] / debian / rules
index 3f7052b..e0b4109 100755 (executable)
@@ -1,17 +1,9 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
-
 CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -23,7 +15,6 @@ endif
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
 
        touch configure-stamp
 
@@ -33,10 +24,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       # Add here commands to compile the package.
-       #$(MAKE)
        pod2man sendxmpp > sendxmpp.1
-       #docbook-to-man debian/sendxmpp.sgml > sendxmpp.1
 
        touch build-stamp
 
@@ -45,8 +33,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
-       #-$(MAKE) clean
        rm -f sendxmpp.1
 
        dh_clean 
@@ -54,11 +40,9 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs
 
-       # Add here commands to install the package into debian/sendxmpp.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/sendxmpp
        install sendxmpp debian/sendxmpp/usr/bin/
        install -m 422 sendxmpp.1 debian/sendxmpp/usr/share/man/man1/
 
@@ -74,24 +58,12 @@ binary-indep: build install
        dh_installchangelogs Changes
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
        dh_perl
-#      dh_python
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol